Networker Interview

Prepare for CCNA, CCNP, CCIE Interview !

header photo

Router ID Significance in EIGRP, OSPF & BGP

February 11, 2016

EIGRP
The EIGRP RID is a 32-bit number in dotted decimal format. In EIGRP, duplicate RIDs do not prevent routers from becoming neighbors and two EIGRP routers with the same router ID will still form a neighbor relationship. The only time the value of EIGRP RIDs consider is when injecting external (redistributed) routes into EIGRP. In this case, the routers injecting the external routes should have unique RIDs to avoid confusion.
To manually configures the router ID
R1(config)# router eigrp 10
R1(config-router)# eigrp router-id 1.1.1.1

OSPF
Every OSPF router within the network will have a 32 bit number router ID that uniquely identifies it to the other routers on the network. Unlike EIGRP, OSPF prevents neighborships between routers with duplicate RIDs. All OSPF RIDs in a domain should be unique. OSPF Router ID should not be changed after the OSPF process is started and the ospf neighborships are established. If you change the OSPF router ID, we need to either reload the IOS or use "clear ip ospf process" command (restart the OSPF process) for changed RID to take effect.
To manually configure the router ID
R1(config)# router ospf 5
R1(config-router)# router-id 5.5.5.5

BGP
Like OSPF, BGP also prevents neighborship between routers with same router ID. The BGP router IDs of the two routers should not be same. Router ID also acts as a tie-breaker for BGP path selection. If all other attributes (weight, local preference, origin, AS path etc) till router ID are equal than decision is made based on lowest router ID.
To manually configure the router ID
R1(config)# router bgp 100
R1(config-router)# bgp router-id 9.9.9.9

In all of above routing protocols Router ID is determined according to the following general rules -
Step 1. Use the router ID defined in the router-id x.x.x.x OSPF router subcommand.
Step 2. Use the highest IP address of any up loopback interface.
Step 3. Use the highest IP address of any up physical interface.

 

Passive Interface command Behavior in RIP, EIGRP & OSPF

February 9, 2016

RIP
In RIP passive-interface command will disable sending multicast updates via a specific interface but will allow listening to incoming updates from other RIP speaking neighbors.
R1# router rip
R1# passive-interface fa0/0

Command to see list of passive-interfaces
R1# show ip protocols

EIGRP
When an interface is passive, EIGRP quits sending any outgoing hello packets, so the router can not form any neighbor relationship via passive interface. This behavior stops both outgoing and incoming routing updates. However, EIGRP still advertises the connected subnets if matched with an EIGRP network command.
R1# router eigrp 1
R1# passive-interface fa0/0

Command to see list of passive-interfaces
R1# show ip protocols

OSPF
It works just like it works with EIGRP. When a router configures an interface as passive to OSPF, OSPF stops sending outgoing hello packets, so the router can not form any neighbor relationship via the passive interface. This behavior stops both outgoing and incoming routing updates. However, OSPF still advertises the connected subnets if matched with an OSPF network command.
R1# router ospf 3
R1# passive-interface fa0/0
Command to see list of passive-interfaces
R1# show ip protocols

 

List of Protocols which works on TCP and UDP?

January 31, 2016

 

TCP UDP
TELNET, HTTP, HTTPS, FTP, SMTP, BGP, POP3, IMAP, NFS. DHCP, TFTP, DNS, RIP, SNMP, VOIP.

 

 

Comparison of RIP, EIGRP & OSPF ?

January 31, 2016

 

  RIP EIGRP OSPF
Type Distance Vector Advanced Distance Vector Link state
Subnet Mask Classfull (By Default) Classfull (By Default) Classless
Algorithm Bellman-Ford Diffusing Update (DUAL) Dijkastra
AD Value 120 90 110
Maximum Hops 15 100 to 255 Unlimited
Layer Works on Transport Layer Works on Network Layer Works on Network Layer
Port/ Protocol No 520 88 89
Metric Hop Counts K-Values Cost
Multicast Address 224.0.0.9 224.0.0.10 224.0.0.5, 224.0.0.6

Neighborship

Requirements

      -------------------------- AS, K-Values, Authentication.

Area ID, Hello Interval,

Dead Time, Authentication.

Timers

Update - 30 sec, Hold - 180 sec

Invalid - 180 sec, Flush - 240sec

Hello - 5 sec, Hold - 15 sec Hello -10 sec, Dead - 40 sec
Authentication

Version1- No Authentication

Version 2 - Plain Text & MD5

MD5 Type 0, Plain Text, MD5